Вы здесь

После авторизации у пользователей некорректно отображается блок views

0

Сегодня решил зайти на сайт как обычный пользователь....
Авторизуюсь и смотрю блок созданная через вьюс криво отображается!В смысле элементы внутри блока криво отображаются.

Но что интересно когда авторизуюсь как админ все нормально... это че за мистика??)))

Проверил все настройки...вроде все как надо.Я подумал ну-ка выключу кеширование блока !

Выключил кеширование ,вышел как админ и зашел снова как обычный пользователь и смотрю все на месте!

Проблема в включении кешировании блока.

И что мне теперь делать??Не включать кеширование вообще и все??

Версия Drupal: 
7.x
Вопрос задан 21.11.2015 - 00:07

вам надо уточнить, что значит "криво". если у вас стили не работают, проверьте в фаербаге.

Комментарий оставлен 21.11.2015 - 00:10

Завтра картинки постараюсь сделать и добавить сюда. Сегодян просто уже поздно.Пока временно отключу кеширование думаю ничего страшного не будет.

Просто вся проблема в кешировании. Если кеширование выключать то нормально все отображается.Я не могу просто понять почему так. Может время кеширование не правильно ставлю??

Оно должно быть одинаковое как и встроенное кеширование??

Комментарий оставлен 21.11.2015 - 00:14

я тоже не знаю. может быть вы попробуете модуль Views Content Cache - по содержанию а не по времени?

Комментарий оставлен 21.11.2015 - 00:38

Сорри, а что означает "блок созданная через вьюс"?

Комментарий оставлен 21.11.2015 - 04:13

Может не все разрешения прописаны?

Комментарий оставлен 21.11.2015 - 10:21

Опишите проблему нормально. А то я только что прочитал поток эмоций для нового расследования экстрасенсов, а не описание проблемы.

Комментарий оставлен 21.11.2015 - 11:30

Сорри, а что означает "блок созданная через вьюс"?

Новичок?)
Есть такой модуль "views". Напишите "views друпал 7" в гугле и найдете описания модуля,а именно для чего он нужен и даже как установить и работать)

Комментарий оставлен 21.11.2015 - 21:07

Извиняйте что не понятно объяснил))

Короче, есть блок на сайте.Блок сделан посредством views и вывожу последние материалы сайта(как анонс).
Когда включаю кэширование блока в настройках вьюса,в отображении этого блока элементы "плывут" .

ВЫключаю кэширование,после смотрю все работает идеально и все на своих местах!

Комментарий оставлен 21.11.2015 - 21:19

Вот посмотрите если делать такие настройки все портится:

Комментарий оставлен 21.11.2015 - 21:25

Я думаю что скорее сам не правильно настраиваю. Как правильно включать кэширование блоков во вьюсе??

Комментарий оставлен 21.11.2015 - 21:26

Ответы

0

кэш очистить не пробовали?) может быть правки в верстке были, пока не очистите будете получать старые стили, потому и ползет все..

Ответ дан 21.11.2015 - 02:26

кэш я миллион раз уже почистил))я же не совсем новичок чтобы этот момент упустить))
Вся проблема в настройках вьюса. А точнее в кэшировании блоков. Как отключаю кэширование все становится на свои места.Включаю....все портится.

Комментарий оставлен 21.11.2015 - 21:00