Вы здесь

Как с помощью Maxlength установить максимальное количество символов в Summary

0

Доброго времени суток всем

Есть сайт, на котором возникла необходимость ограничить Summary в символах.

Поискав варианты решения, нашел модуль специально предназначенный для этого - Maxlength

Что я делаю:

  1. Устанавливаю как обычно модуль
  2. Захожу в Administration » Structure » Content types » Article » Manage fields
  3. Далее напротив поля Body нажимаю edit
  4. В поле Summary Maxlength JS - ставлю 250 символов
  5. В поле Maxlength JS - тоже ставлю 250 символов
  6. Сохраняю
  7. Далее - Создание материала Article

Поле body не имеет ограничению в символах, нажимаю "Редактировать анонс", тоже все пусто, ограничений нет

Что я делаю не так?

Заранее всем благодарен за помощь

Версия Drupal: 
7.x
Связанные проекты: 
Maxlength
Вопрос задан 28.12.2015 - 19:55

Ответы

0

Что я делаю не так?

Тестируешь от uid=1 - тестируй от другого юзера ( и у роли не должен быть отмечен permission "Bypass maxlength setting" судя по http://cgit.drupalcode.org/maxlength/tree/maxlength.module#n162 )

Чтобы выводить админу нужно в settings.php добавить:

$conf['maxlength_always_for_uid1'] = TRUE; 
Ответ дан 28.12.2015 - 22:58
Аватар пользователя drupby
drupby
456

Да, так работает, благодарю за помощь, ваш ответ очень помог мне

Комментарий оставлен 29.12.2015 - 07:40