Вы здесь

После обновления D6 > D7 не работают ни CKEditor, ни другие редакторы WYSIWYG, как починить?

0

Добрый день, уважаемые друпалеры. После обновления D6>D7 сломался ckeditor - тупо не видно редактора при создании/редактирования ноды. Модуль, естественно, тоже обновлял, update.php запускал, библиотека присутствует в папке sites/all/libraries/ckeditor, права на папку выставлял 777, но редактор не появляется. CDN-версию тоже пробовал, все снести и заново скачать - тем более, результат тот же. После пробовал отключить модуль ckeditor, включить через WYSIWYG. Как результат: ckeditor, tinymce, jWYSIWYG не подключились, т.к.

"The version of %name% could not be detected."

openWYSIWYG - подключился, но окно редактора все равно не появляется. Словом, пипец. Вопрос: что я делаю не так? Была ли у кого-нибудь похожая проблема?
UPD:
Прочитал здесь, что новые версии CKeditor почему-то могут лагать, скачал непосредственно старую версию CKEditor 3.5 вместо 4.5.6, появилось окно редактора, но без кнопок, думаю скоро проблема решится

Версия Drupal: 
7.x6.x
Вопрос задан 19.01.2016 - 13:01

возможно ошибка в js, что показывает консоль браузера?

Комментарий оставлен 19.01.2016 - 13:19

Ответы

0

скорее всего не настроен формат ввода

Ответ дан 19.01.2016 - 13:25

Нет, CKeditor не был вообще виден в списке редакторов для выбранных текстовых форматов.

Комментарий оставлен 19.01.2016 - 14:01
0
  1. Тупо сначала версию посмотреть - стопудово древняя.
  2. Грохнуть всё нафик и поставить свежую версию по феншую
    это же касается и некоторых модулей
Ответ дан 19.01.2016 - 13:45
Аватар пользователя Pavel
Pavel
-47
0

Если редактор не отображается, то скорее всего конфликт js. Смотрите в Firebug. У меня когда-то была такая проблема.

Ответ дан 19.01.2016 - 14:22
0

Попробовать другую тему оформления, для начала, лучше из ядрёных - bartik, например

Ответ дан 19.01.2016 - 18:22
0

Решение: После некоторого кол-ва гугления и экспериментов с ckeditor, удалось выяснить, что связка WYSIWYG + Ckeditor версии 3.5 или 3.6 работают. Если обновить WYSIWYG на dev-версию, то заработают и версии >4. (в том числе и последняя на данный момент ckeditor-4.5.6). С помощью модуля ckeditor данную проблему не удалось решить.
После установки WYSIWYG и библиотеки надо не забыть выбрать ckeditor в настройках форматов (admin/config/content/wysiwyg), а также выбрать набор кнопок-плагинов в настройках. Всем спасибо за помощь.

Ответ дан 20.01.2016 - 13:26