Вы здесь

Drush работает под Drupal 8?

0

Поставил Drupal 8, пробую команду

drush st

Drush
Другие команды не работаю, например drush up. Работает ли Drush корректно на 8, или я не правильно что-то делаю?

ПС. Спасибо всем кто ответил, поставил стабильную версию все заработало.

Если у вас возникает ошибка:

in_array() expects parameter 2 to be array, null given DrupalBoot.php:503

То скорее всего проблема из-за наличия двух файлов SQLite в папке "sites/default/files".

Версия Drupal: 
8.x
Связанные проекты: 
Drush
Вопрос задан 19.01.2016 - 23:20

У вас база данных друпал крутится на sqlite?

Комментарий оставлен 20.01.2016 - 07:11

У вас база данных друпал крутится на sqlite?

Да.

Комментарий оставлен 20.01.2016 - 12:08

Ответы

2

Да, после обновления работает, проверено у себя.
Вот статья для апгрейда: https://drupalize.me/blog/201408/upgrading-drush-work-drupal-8

Ответ дан 20.01.2016 - 02:53


у меня так. У вас там какая-то ошибка in_array. Посмотрите логи.
Да еще разница, у вас drush - dev, у меня 8.0.1 - но не думаю что из-за этого, но стоит проверить...

Комментарий оставлен 20.01.2016 - 05:59

у меня работает. ставьте последнюю стабильную версию (8.0.2.)

Комментарий оставлен 20.01.2016 - 11:32

у меня работает. ставьте последнюю стабильную версию (8.0.2.)

Наверное из-за версии Drush не работает. Попробую поставить стабильную.

Комментарий оставлен 20.01.2016 - 12:10
0

Нуно ставить последнюю используя компосер

Ответ дан 21.01.2016 - 08:04

Вы думаете я не через Компосер ставил? :)

Комментарий оставлен 21.01.2016 - 17:41

Что говорит whereis drush?

Я поставил стабильную версию и все работает.

Комментарий оставлен 31.01.2016 - 02:08