Вы здесь

Модуль Auto-dialog не работает совместно с NodeJs

0

Вообщем после тренировки с сервером Node js и его подключением к drupal сайту, выявилось следующее.

Если через модуль Jquery update установить версию Jquery выше 1.7 то все ссылки Auto-dialog перестают открываться и вываливается ошибка Ajax 200. Если стоит версия 1.7 то все прекрасно работает!

При активном сервере Node js модуль auto-dialog вообще перестает открывать ссылки показывая ошибку - Cannot read property 'apply' of undefined.
При выключенном сервере все работает но только если версия jquery 1.7

На чистом друпал сайте все эти модули в куче отлично работают! при этом независимо от версии jquery. Сервер node js так же работает.
Подскажите как отловить того кто вредит?

Версия Drupal: 
7.x
Вопрос задан 13.11.2016 - 22:00

Ответы

0

Причина, данной ошибки была в неправильной кодировке info файла кастомного модуля (mymodule.info), а именно установленная галочка "Включить подпись в формате unicode BOM", будьте внимательней! ))

Ответ дан 19.11.2016 - 20:15