Вы здесь

При обращении к сайту по https, возникают ошибки Mixed Content

0

Всем привет ! Срочно нужна помощь Друпал мастеров))

Недавно сайт по адресу https вдруг стал криво отображаться..слетели все стили и скрипты...
Через http работает все как надо.Понял что проблема в настройках https. Но что странно, такого не было до вчерашнего дня.

Вон ошибка :

Mixed Content: The page at 'https://мойсайт.ru/' was loaded over HTTPS, but requested an insecure script 'http://мойсайт.ru/sites/default/files/js/js_tm1gahPj5RurExr4Zj4GdGvvL7W4-u6_XRVeEsXyp3Q.js'. This request has been blocked; the content must be served over HTTPS.

Обратился в хостинг за помощью.Они нашли вроде бы проблему. Говорят что необходимо изменить все статически ссылки с http на https, включая ссылки на шрифты .

Что делать не знаю. Помогите пожалуйста мне очень прошу!!!

Версия Drupal: 
7.x
Вопрос задан 10.09.2017 - 22:12

Ответы

1

Недавно решал подобную проблему. Мне помогло в settings.php расскоментить и изменить строку:

$base_url = 'https://site.ru';

Т.е. указать явный https протокол, и свой сайт, для большинства ресурсов сайта этого будет достаточно, останется изменить ссылки, которые были вручную добавлены в шаблоны или ещё куда-то, если таковы имеются.

Ответ дан 11.09.2017 - 11:09
Аватар пользователя Apuox
Apuox
15

Хотя я решение нашел до вашего ответа но тем не менее вы направили в нужное направление.Спасибо вам большое за внимание!

Комментарий оставлен 11.09.2017 - 20:41
0

Решение нашел в англоязычных сайтах. Там все просто.У меня в $base_url был указан адрес именно с http . А там пишут чтобы сайт работал нормально там и там нужно оставить заводские настройки .

Но тут хитрость. Когда я это поправил...сайт продолжал отображаться криво.Я подумал что это не помогло...но сегодня на свежую голову стал дальше копаться...и оказалось что браузер запомнил все эти ошибки...очистил кэш браузера и другой мусор сохранненый в нем...открыл сайт смотрю все стало на свои места!Ура!!!!

Ответ дан 11.09.2017 - 20:34